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3D	
  Slicer	
  version	
  4	
  (Slicer4.1)	
  

•  An	
  end-­‐user	
  applica:on	
  for	
  
image	
  analysis	
  

•  An	
  open-­‐source	
  
environment	
  for	
  soKware	
  
development	
  	
  

•  A	
  soKware	
  plaMorm	
  that	
  is	
  
both	
  easy	
  to	
  use	
  for	
  clinical	
  
researchers	
  and	
  easy	
  to	
  
extend	
  for	
  programmers	
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Slicer Modules 

•  Command Line Interface (CLI): 
standalone executables with limited input/
output arguments 
 

•  Scripted Modules (Python): 
recommended for fast prototyping 

•  Loadable Modules (C++ Plugins)
optimized for heaving computation 
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Slicer4	
  	
  Highlights:	
  Python	
  	
  

The	
  Python	
  console	
  of	
  Slicer4	
  gives	
  access	
  to	
  	
  
•  scene	
  objects	
  (MRML)	
  
•  data	
  arrays	
  (volumes,	
  models)	
  
•  GUI	
  elements	
  that	
  can	
  be	
  encapsulated	
  in	
  a	
  

module	
  
•  Processing	
  Libraries:	
  numpy,	
  VTK,	
  ITK,CTK	
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Slicer4	
  Scripted	
  Modules	
  

•  Python	
  scripted	
  modules	
  allow	
  more	
  
interac(ve	
  func(onali(es	
  (eg	
  ‘Flythrough’	
  in	
  
Endoscopy	
  module)	
  and	
  rapid	
  prototyping	
  

•  GUI	
  based	
  on	
  Qt	
  libraries	
  accessed	
  via	
  Python	
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Tutorial	
  Goal	
  

•  This	
  tutorial	
  guides	
  you	
  through	
  the	
  steps	
  of	
  
programming	
  a	
  HelloPython	
  scripted	
  module	
  
for	
  running	
  a	
  Laplacian	
  filtering	
  and	
  
sharpening.	
  

•  For	
  addi:onal	
  details	
  and	
  pointers,	
  visit	
  the	
  
Slicer	
  Documenta:on	
  page	
  

h^p://wiki.slicer.org/slicerWiki/index.php/Documenta:on/4.0	
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Processing Examples in this 
Tutorial 

Image Data on 
Disk (DICOM, 
Nifti, nrrd…) 

MRML Scene 

Manipulation 
with numpy 

Manipulation 
with VTK 

Manipulation 
with ITK 
(Slicer CLI) 

MRML: Medical Reality Markup Language, 
the Slicer Data Representation 

S.Pujol, Ph.D. - S.Pieper, Ph.D. 
 NA-MIC ARR 2012-2014 



Prerequisites	
  

•  This	
  course	
  supposes	
  that	
  you	
  have	
  taken	
  the	
  
tutorial:	
  “Slicer4	
  Data	
  Loading	
  and	
  
Visualiza:on”-­‐	
  Sonia	
  Pujol	
  Ph.D.	
  

•  The	
  tutorial	
  is	
  available	
  on	
  the	
  Slicer4	
  101	
  
compendium:	
  

h^p://www.slicer.org/slicerWiki/index.php/Training/4.0	
  	
  

•  Programming	
  experience	
  is	
  required,	
  and	
  
some	
  familiarity	
  with	
  Python	
  is	
  essen:al.	
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Course	
  Material	
  

Unzip the HelloPython.zip archive 

spgr.nhdr	
  spgr.raw.gz	
  
(124	
  SPGR	
  images)‏	
  

HelloPython.py 
HelloLaplace.py 
HelloSharpen.py  
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Course	
  Overview	
  

•  Part	
  A:	
  Exploring	
  Slicer	
  via	
  Python	
  

•  Part	
  B:	
  Integra:on	
  of	
  the	
  HelloPython.py	
  
program	
  into	
  Slicer4	
  

•  Part	
  C:	
  Implementa:on	
  of	
  the	
  Laplace	
  
operator	
  in	
  the	
  HelloPython	
  module	
  

•  Part	
  D:	
  Image	
  Sharpening	
  using	
  the	
  Laplace	
  
operator	
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Part	
  A:	
  EXPLORING	
  SLICER	
  VIA	
  
PYTHON	
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Python	
  in	
  Slicer	
  

•  Slicer	
  4	
  includes	
  python	
  2.6.6	
  and	
  a	
  rich	
  set	
  of	
  
standard	
  libraries	
  

•  Included:	
  numpy,	
  vtk,	
  ctk,	
  PythonQt,	
  and	
  
most	
  of	
  standard	
  python	
  library	
  

•  Not	
  included:	
  	
  
-­‐  scipy	
  (scien:fic	
  tools	
  for	
  python),	
  	
  
-­‐  matplotlib	
  (python	
  2D	
  plo:ng	
  library),	
  	
  
-­‐  ipython	
  (interac:ve	
  python)	
  	
  
and	
  some	
  other	
  popular	
  packages	
  that	
  we	
  
have	
  found	
  difficult	
  to	
  package	
  for	
  distribu:on	
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Python	
  Console	
  in	
  Slicer	
  

Select View -> Python Interactor to 
launch the Python console of Slicer 
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General	
  Python	
  Console	
  Features	
  

•  Command	
  Line	
  Edi:ng:	
  
•  LeK/Right	
  Arrow	
  Keys,	
  Home,	
  End	
  
•  Delete	
  (Control-­‐D)	
  

•  Input	
  History	
  
•  Up/Down	
  Arrow	
  Keys	
  

•  Command	
  Comple:on	
  
•  Tab	
  Key	
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Add	
  Volume	
  Dialog	
  

Select File -> Add Volume 
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Add	
  spgr.nhdr	
  

Load the dataset spgr.nhdr 
located in the directory 
HelloPython/ 
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Access	
  to	
  MRML	
  and	
  Arrays	
  
Run the following code in the 
Python console 

a = slicer.util.array('spgr’) 
	
  
àUses	
  the	
  slicer.u:l	
  package	
  to	
  
	
  return	
  a	
  numpy	
  array	
  of	
  the	
  image	
  
àThe	
  variable	
  'a'	
  is	
  a	
  numpy	
  ndarray	
  	
  
of	
  the	
  volume	
  data	
  we	
  just	
  loaded	
  	
  
 
print( a ) 
àShows	
  a	
  shortened	
  view	
  of	
  the	
  array	
  
 

S.Pujol, Ph.D. - S.Pieper, Ph.D. 
 NA-MIC ARR 2012-2014 



Access	
  to	
  MRML	
  and	
  Arrays	
  
The intensity values of the spgr 
image appear in the Python 
console 
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Access	
  to	
  MRML	
  and	
  Arrays	
  
Type the following command to 
display the min and max 
intensity value of the spgr image 

print( a.min(), a.max() ) 

 
àUse	
  numpy	
  array	
  methods	
  	
  
to	
  analyze	
  the	
  data 	
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Access	
  to	
  MRML	
  and	
  Arrays	
  
I min = 0 ; I max = 355 
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Manipula:ng	
  Arrays	
  
Run the following code in the Python console, 
(indent each new line with 2 spaces) 

def toggle(): 
  n = slicer.util.getNode('spgr') 
  a = slicer.util.array('spgr') 
  a[:] = a.max()/2. - a 
  n.GetImageData().Modified() 
  print('Toggled') 
 
toggle() 

For practice:  use up arrow and return 
keys to execute toggle() over and over 



Manipula:ng	
  Arrays	
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The	
  toggle	
  func:on	
  in	
  more	
  detail	
  

•  	
  def	
  toggle():	
  
•  Defines	
  a	
  python	
  func:on	
  
•  Body	
  of	
  func:on	
  performs	
  element-­‐wise	
  

math	
  on	
  en:re	
  volume	
  
•  Easy	
  mix	
  of	
  scalar	
  and	
  volume	
  math	
  

•  Telling	
  slicer	
  that	
  the	
  image	
  data	
  for	
  node	
  'n'	
  
has	
  been	
  modified	
  causes	
  the	
  slice	
  view	
  windows	
  
to	
  refresh	
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Qt	
  GUI	
  in	
  Python	
  
Run the following code in the 
Python console 

b = qt.QPushButton('Toggle') 
b.connect('clicked()', toggle) 
b.show() 

What do you think will happen when you 
run this code?  What about when you 
push the button? 



Result with button toggling 
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Result with button toggling 
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In	
  More	
  Detail	
  

-­‐	
  Slicer	
  uses	
  PythonQt	
  to	
  expose	
  the	
  Qt	
  library	
  
	
  
-­‐	
  Sophis:cated	
  interac:ve	
  modules	
  can	
  be	
  wri^en	
  
en:rely	
  with	
  Python	
  code	
  calling	
  C++	
  code	
  that	
  is	
  
wrapped	
  in	
  Python	
  (e.g.	
  Endoscopy,	
  Editor,	
  
SampleData,	
  ChangeTracker,	
  and	
  other	
  slicer	
  
modules	
  in	
  the	
  Slicer	
  source	
  code)	
  

(*)	
  Qt:	
  h^p://qt.nokia.com	
  	
  
(**)	
  PythonQt:	
  h^p://pythonqt.sf.net	
  /F.Link	
  (MeVis)	
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PART	
  B:	
  INTEGRATION	
  OF	
  THE	
  
HELLOPYTHON	
  TUTORIAL	
  TO	
  

SLICER4	
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HelloPython.py	
  

Open the file HelloPython.py 
located in the directory HelloPython 
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HelloPython.py	
  

Module 
Description 

Module GUI 

Processing 
Code 
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Module	
  Descrip:on	
  
class HelloPython: 
  def __init__(self, parent): 
    parent.title = "Hello Python" 
    parent.categories = ["Examples"] 
    parent.dependencies = [] 
    parent.contributors = ["Jean-Christophe Fillion-Robin (Kitware)",  
                           "Steve Pieper (Isomics)",  
                           "Sonia Pujol (BWH)"] # replace with "Firstname Lastname (Org)" 
    parent.helpText = """ 
    Example of scripted loadable extension for the HelloPython tutorial. 
    """ 
    parent.acknowledgementText = """ 
    This file was originally developed by Jean-Christophe Fillion-Robin, Kitware Inc., 
Steve Pieper, Isomics, Inc., and Sonia Pujol, Brigham and Women's Hospital and was  
partially funded by NIH grant 3P41RR013218-12S1 (NAC) and is part of the National Alliance  
for Medical Image Computing (NA-MIC), funded by the National Institutes of Health through 
the NIH Roadmap for Medical Research, Grant U54 EB005149.""" # replace with organization, 
grant and thanks. 
    self.parent = parent 

This code is 
provided in  
the template 

constructor 
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Module	
  GUI	
  
  def setup(self): 
    # Instantiate and connect widgets ... 
 
    # Collapsible button 
    sampleCollapsibleButton = ctk.ctkCollapsibleButton() 
    sampleCollapsibleButton.text = "A collapsible button" 
    self.layout.addWidget(sampleCollapsibleButton) 
 
    # Layout within the sample collapsible button 
    sampleFormLayout = qt.QFormLayout(sampleCollapsibleButton) 
 
    # HelloWorld button 
    helloWorldButton = qt.QPushButton("Hello world") 
    helloWorldButton.toolTip = "Print 'Hello world' in standard ouput." 
    sampleFormLayout.addWidget(helloWorldButton) 
    helloWorldButton.connect('clicked(bool)', self.onHelloWorldButtonClicked) 
 
    # Add vertical spacer 
    self.layout.addStretch(1) 
 
    # Set local var as instance attribute 
    self.helloWorldButton = helloWorldButton 
 

Add this 
Text in  
section A 
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Processing	
  Code	
  

	
  
	
  	
  def	
  onHelloWorldBu^onClicked(self):	
  
	
  	
  	
  	
  print	
  "Hello	
  World	
  !"	
  
	
  	
  	
  	
  qt.QMessageBox.informa(on(	
  
	
  	
  	
  	
  	
  	
  	
  	
  slicer.u(l.mainWindow(),	
  
	
  	
  	
  	
  	
  	
  	
  	
  'Slicer	
  Python',	
  'Hello	
  World!')	
  
	
  
	
  

Add this 
Text in  
section B 
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Integra:ng	
  HelloPython	
  

Select Module Settings 
from the  
Edit -> Application 
Settings Dialog 

Open the side 
panel and click 
Add 
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Integra:ng	
  HelloPython	
  

Add the path to the 
directory containing 
HelloPython.py  
(when selecting the 
directory, the 
HelloWorld.py file itself 
will not be displayed) 
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HelloPython in Slicer 
Restart Slicer when prompted. 
Hello Python is now in the 
Modules Menu, under the 
category Examples 
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HelloPython in Slicer 
Click on Help and 
Acknowledgment  
in the Hello Python module 

Expand the ‘A Collapsible button’ tab,  
and click on the Hello World button  
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Part	
  C:	
  
Implemen:ng	
  the	
  
Laplace*	
  Operator	
  

*named	
  aKer	
  Pierre-­‐Simon,	
  	
  Marquis	
  de	
  Laplace	
  (1749-­‐1827)	
  	
  

Text	
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Overview	
  
The	
  goal	
  of	
  this	
  sec:on	
  is	
  	
  to	
  build	
  an	
  image	
  
analysis	
  module	
  that	
  implements	
  a	
  Laplacian	
  filter	
  
on	
  volume	
  data	
  

•  Use	
  qMRML	
  widgets:	
  widgets	
  
that	
  automa:cally	
  track	
  the	
  
state	
  of	
  the	
  Slicer	
  MRML	
  
scene	
  

•  Use	
  VTK	
  filters	
  to	
  manipulate	
  
volume	
  data	
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HelloLaplace.py	
  

Open the file HelloLaplace.py 
located in the directory HelloPython 
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Module	
  GUI	
  (Part	
  1)	
  
 def setup(self): 
    # Collapsible button 
    self.laplaceCollapsibleButton = ctk.ctkCollapsibleButton() 
    self.laplaceCollapsibleButton.text = "Laplace Operator" 
    self.layout.addWidget(self.laplaceCollapsibleButton) 
 
    # Layout within the laplace collapsible button 
    self.laplaceFormLayout = qt.QFormLayout(self.laplaceCollapsibleButton) 
 
    # the volume selectors 
    self.inputFrame = qt.QFrame(self.laplaceCollapsibleButton) 
    self.inputFrame.setLayout(qt.QHBoxLayout()) 
    self.laplaceFormLayout.addWidget(self.inputFrame) 
    self.inputSelector = qt.QLabel("Input Volume: ", self.inputFrame) 
    self.inputFrame.layout().addWidget(self.inputSelector) 
    self.inputSelector = slicer.qMRMLNodeComboBox(self.inputFrame) 
    self.inputSelector.nodeTypes = ( ("vtkMRMLScalarVolumeNode"), "" ) 
    self.inputSelector.addEnabled = False 
    self.inputSelector.removeEnabled = False 
    self.inputSelector.setMRMLScene( slicer.mrmlScene ) 
    self.inputFrame.layout().addWidget(self.inputSelector) 
 
 
 

This code is 
provided in  
the template 
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Module	
  GUI	
  (Part	
  2)	
  
    self.outputFrame = qt.QFrame(self.laplaceCollapsibleButton) 
    self.outputFrame.setLayout(qt.QHBoxLayout()) 
    self.laplaceFormLayout.addWidget(self.outputFrame) 
    self.outputSelector = qt.QLabel("Output Volume: ", self.outputFrame) 
    self.outputFrame.layout().addWidget(self.outputSelector) 
    self.outputSelector = slicer.qMRMLNodeComboBox(self.outputFrame) 
    self.outputSelector.nodeTypes = ( ("vtkMRMLScalarVolumeNode"), "" ) 
    self.outputSelector.setMRMLScene( slicer.mrmlScene ) 
    self.outputFrame.layout().addWidget(self.outputSelector) 
 
    # Apply button 
    laplaceButton = qt.QPushButton("Apply Laplace") 
    laplaceButton.toolTip = "Run the Laplace Operator." 
    self.laplaceFormLayout.addWidget(laplaceButton) 
    laplaceButton.connect('clicked(bool)', self.onApply) 
 
    # Add vertical spacer 
    self.layout.addStretch(1) 
 
    # Set local var as instance attribute 
    self.laplaceButton = laplaceButton 
 

This code is 
provided in  
the template 
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In	
  More	
  Detail	
  

•  CTK	
  is	
  a	
  Qt	
  Add-­‐On	
  Library	
  with	
  many	
  useful	
  
widgets,	
  par:cularly	
  for	
  visualiza:on	
  and	
  medical	
  
imaging	
  see	
  h^p://commontk.org	
  

•  Qt	
  Widgets,	
  Layouts,	
  and	
  Op:ons	
  are	
  well	
  
documented	
  at	
  h^p://qt.nokia.com	
  

•  qMRMLNodeComboBox	
  is	
  a	
  powerful	
  slicer	
  widget	
  
that	
  monitors	
  the	
  scene	
  and	
  allows	
  you	
  to	
  select/
create	
  nodes	
  of	
  specified	
  types	
  (example:	
  here	
  we	
  
use	
  Volumes	
  =	
  vtkMRMLScalarVolumeNode)	
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  def onApply(self): 
    inputVolume = self.inputSelector.currentNode() 
    outputVolume = self.outputSelector.currentNode() 
    if not (inputVolume and outputVolume): 
      qt.QMessageBox.critical(slicer.util.mainWindow(), 
          'Laplace', 'Input and output volumes are required for Laplacian') 
      return 
    laplacian = vtk.vtkImageLaplacian() 
    laplacian.SetInput(inputVolume.GetImageData()) 
    laplacian.SetDimensionality(3) 
    laplacian.GetOutput().Update() 
    ijkToRAS = vtk.vtkMatrix4x4() 
    inputVolume.GetIJKToRASMatrix(ijkToRAS) 
    outputVolume.SetIJKToRASMatrix(ijkToRAS) 
    outputVolume.SetAndObserveImageData(laplacian.GetOutput()) 
    # make the output volume appear in all the slice views 
    selectionNode = slicer.app.applicationLogic().GetSelectionNode() 
    selectionNode.SetReferenceActiveVolumeID(outputVolume.GetID()) 
    slicer.app.applicationLogic().PropagateVolumeSelection(0) 
 

Processing Code 
 
 

Add this  
code 
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In	
  More	
  Detail	
  

•  vtkImageLaplacian	
  is	
  a	
  vtkImageAlgorithm	
  operates	
  
on	
  vtkImageData	
  (see	
  h^p://vtk.org)	
  

	
  
•  vtkMRMLScalarVolumeNode	
  is	
  a	
  Slicer	
  MRML	
  class	
  

that	
  contains	
  vtkImageData,	
  plus	
  orienta:on	
  
informa:on	
  ijkToRAS	
  matrix	
  (see	
  h^p://
www.slicer.org/slicerWiki/index.php/
Coordinate_systems)	
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In	
  More	
  Detail	
  (Con:nued)	
  

Global	
  slicer	
  package	
  gives	
  python	
  access	
  to:	
  
1-­‐	
  GUI	
  (via	
  slicer.app)	
  
2-­‐	
  modules	
  (via	
  slicer.modules)	
  
3-­‐	
  data	
  (via	
  slicer.mrmlScene)	
  
	
  
slicer.app.applica(onLogic()	
  provides	
  helper	
  
u:li:es	
  for	
  manipula:ng	
  Slicer	
  state	
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Go To Laplace Module 

Re-start Slicer and select 
module.  Note that 
combobox is empty  
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Add	
  Volume	
  Dialog	
  

Select File -> Add Volume 
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Add	
  spgr.nhdr	
  

Load the dataset spgr.nhdr 
located in the directory 
HelloPython/ 
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AKer	
  Adding	
  Volume	
  
(1) Note that Input Volume combobox 
autoselected new volume 

(2) Create new volume for output 

(3) Run the module 
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 Laplace Module 

Result of Laplace Operator 
on spgr volume 
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Part	
  D:	
  
Image	
  Sharpening	
  with	
  
the	
  Laplace	
  Operator	
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Overview	
  

•  	
  The	
  goal	
  of	
  this	
  sec:on	
  is	
  
to	
  add	
  a	
  processing	
  op:on	
  
for	
  image	
  sharpening.	
  	
  

•  We’ll	
  implement	
  this	
  
opera:on	
  using	
  	
  the	
  
exis:ng	
  Slicer	
  Command	
  
Line	
  Module	
  	
  

•  ‘Subtract	
  Scalar	
  Volumes’	
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HelloSharpen.py	
  

Open the file HelloSharpen.py 
located in the directory HelloPython 
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Add	
  to	
  Module	
  GUI	
  
    ... 
    self.outputSelector.setMRMLScene( slicer.mrmlScene ) 
    self.outputFrame.layout().addWidget(self.outputSelector) 
 
    self.sharpen = qt.QCheckBox("Sharpen", self.laplaceCollapsibleButton) 
    self.sharpen.toolTip = "When checked, subtract laplacian from input volume" 
    self.sharpen.checked = True 
    self.laplaceFormLayout.addWidget(self.sharpen) 
 
    # Apply button 
    laplaceButton = qt.QPushButton("Apply") 
    laplaceButton.toolTip = "Run the Laplace or Sharpen Operator." 
    ... 
 
 
 
 

Add this 
Text in  
section A 
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    ... 
    outputVolume.SetAndObserveImageData(laplacian.GetOutput()) 
    # optionally subtract laplacian from original image 
    if self.sharpen.checked: 
      parameters = {} 
      parameters['inputVolume1'] = inputVolume.GetID() 
      parameters['inputVolume2'] = outputVolume.GetID() 
      parameters['outputVolume'] = outputVolume.GetID() 
      slicer.cli.run( slicer.modules.subtractscalarvolumes, None, 
parameters, wait_for_completion=True ) 
    # make the output volume appear in all the slice views 
    selectionNode = slicer.app.applicationLogic().GetSelectionNode() 
    selectionNode.SetReferenceActiveVolumeID(outputVolume.GetID
()) 
    slicer.app.applicationLogic().PropagateVolumeSelection(0) 
   
 

Add to Processing Code 
 
 

Add this 
Text in  
section B 
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In	
  More	
  Detail	
  

•  slicer.cli	
  gives	
  access	
  to	
  Command	
  Line	
  
Interface	
  (CLI)	
  modules	
  

•  CLI	
  modules	
  allow	
  packaging	
  of	
  arbitrary	
  C++	
  
code	
  (oKen	
  ITK-­‐based)	
  into	
  slicer	
  with	
  
automa:cally	
  generated	
  GUI	
  and	
  python	
  
wrapping	
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Go To Sharpen Module 

Re-start Slicer and select 
module.  Note the new 
sharpen check box  
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Add	
  Volume	
  Dialog	
  

Select File -> Add Volume 
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Add	
  spgr.nhdr	
  

Load the dataset spgr.nhdr 
located in the directory 
HelloPython/ 
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AKer	
  Adding	
  Volume	
  
(1) Note that Input Volume combobox 
autoselected new volume 

(2) Create new volume for output 

(3) Run the module in Sharpen 
mode 
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 Sharpen Module 

Result of Laplacian 
Sharpening Operator on 
spgr volume 
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 Sharpen Module 

Adjust Window/Level with 
Left-Mouse-Drag in Slice 
Window 
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original Laplacian filtered Laplacian 

Image Sharpening 
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Going	
  Further	
  

•  Explore	
  numpy	
  for	
  numerical	
  array	
  manipula:on	
  

•  Review	
  Endoscopy	
  Module	
  for	
  interac:ve	
  data	
  
explora:on	
  using	
  MRML	
  and	
  VTK	
  

•  See	
  the	
  Editor	
  Module	
  for	
  interac:ve	
  
segmenta:on	
  examples	
  

•  Explore	
  SimpleITK	
  for	
  image	
  processing	
  using	
  ITK	
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Conclusion 

This	
  course	
  demonstrated	
  how	
  to	
  
program	
  custom	
  behavior	
  in	
  Slicer	
  
with	
  Python	
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